Hoofd Pc & Mac Zijn e-mails hoofdlettergevoelig?

Zijn e-mails hoofdlettergevoelig?



Er is veel verwarring over of e-mailadressen hoofdlettergevoelig zijn of niet. Sommigen zeggen van wel, anderen beweren van niet. Dus, wie heeft gelijk? In dit artikel bekijken we of e-mailadressen hoofdlettergevoelig of niet-hoofdlettergevoelig zijn.

Zijn e-mails hoofdlettergevoelig?

Wat maakt een e-mailadres?

Een e-mailadres bestaat uit drie delen: het lokale deel (ook wel gebruikersnaam genoemd), het @-teken en het domeindeel. Elk onderdeel heeft zijn eigen rol en is onderhevig aan zijn eigen regels. Hier is een snel overzicht.

Volgens de norm mag het lokale deel van het e-mailadres maximaal 64 tekens lang zijn en uit een beperkte set tekens bestaan. Deze omvatten hoofdletters en kleine letters van het Latijnse alfabet, cijfers van 0 tot 9, punt en speciale tekens. De speciale tekens bevatten ` [email protected] #$%^&*()_-+=[]{}~. Het is verbonden met het domeingedeelte met het @-teken.

Het domeingedeelte mag maximaal 255 tekens lang zijn. Het kan letters van het Latijnse alfabet (zowel kleine als hoofdletters), cijfers van 0 tot 9 en koppeltekens bevatten. Het koppelteken kan het domeingedeelte niet beginnen of beƫindigen.

Internationale symbolen kunnen ook worden gebruikt, maar daarover later meer.

Is het hoofdlettergevoelig?

Het juiste antwoord op deze vraag is zowel ja als nee. Volgens RFC 5321 , is het lokale deel van het e-mailadres hoofdlettergevoelig. Dit betekent dat in theorie [email protected] niet hetzelfde is als [email protected] Echter, e-mailproviders hebben de vrijheid om de lokale delen zowel hoofdlettergevoelig als hoofdletterongevoelig te behandelen.

[email protected] , [email protected] en [email protected] zijn bijvoorbeeld theoretisch verschillende e-mailadressen. Het is gemakkelijk in te zien hoe dit problemen zou kunnen veroorzaken en de gebruikerservaring zou kunnen verminderen als een mailserver ervoor zou kiezen om de lokale delen als hoofdlettergevoelig te behandelen. Daarom behandelen veel providers het lokale deel van het e-mailadres als hoofdletterongevoelig.

hoe gifs te downloaden van gfycat

Wat betreft het domeingedeelte, RFC 1035 bepaalt dat het altijd hoofdlettergevoelig is. Dit betekent dat je het in kleine letters, hoofdletters of een combinatie van beide kunt schrijven en je e-mail komt op hetzelfde adres terecht. In de praktijk zijn [email protected] , [email protected] en [email protected] hetzelfde e-mailadres.

In praktijk

Hoewel e-mailadressen slechts gedeeltelijk hoofdlettergevoelig zijn, is het over het algemeen veilig om ze als niet hoofdlettergevoelig te beschouwen. Alle grote providers, zoals Gmail, Yahoo Mail, Hotmail en andere, behandelen de lokale delen van e-mailadressen als hoofdletterongevoelig. Dat gezegd hebbende, moet u de regels controleren van de e-mailprovider waarmee u een e-mail wilt maken.

Aansluitend op het vorige punt, raadt de bovengenoemde RFC 5321 aan om nieuwe e-mailadressen alleen met kleine letters aan te maken om mogelijke verwarring en leveringsproblemen te voorkomen.

Aan de andere kant, als je vriend of collega een e-mailadres heeft met een combinatie van hoofdletters en kleine letters, is het raadzaam om het te schrijven zoals het is wanneer je ze een e-mail stuurt. Als u dit niet doet, kan de e-mail niet worden afgeleverd. Dit is echter geen probleem met grote e-mailproviders zoals Gmail, Yahoo Mail, Hotmail en anderen.

Bovendien is Gmail ook ongevoelig voor stippen in het lokale deel van de e-mail als het gaat om identificatie van gebruikersaccounts. Dit betekent dat als het [email protected]-account bestaat, u zich niet kunt registreren voor [email protected] of [email protected]

internationalisering

Oorspronkelijk konden e-mailadressen alleen worden geregistreerd met de letters van het Latijnse alfabet, cijfers en een beperkte set speciale ASCII-tekens. echter, de IETF (Internet Engineering Task Force) heeft vervolgens regels en standaarden ontwikkeld voor het opnemen van internationale karakters.

RFC6530 was de eerste die het gebruik van internationale karakters opnam en regelde. RFC6531 uitgebreid over de regels en normen. Vervolgens zijn de regels en normen geactualiseerd via RFC6532 en RFC6533 .

U kunt nu een e-mailadres registreren met behulp van een breed scala aan alfabetten, tekens en scripts. Enkele van de meest gebruikte zijn Latijnse karakters met diakritische tekens, Grieks alfabet, traditionele Chinese karakters, Japanse karakters (hiragana, katakana en kanji), Cyrillisch alfabet, verschillende Indiase schriften, evenals een reeks andere.

De opname van en compatibiliteit met internationale e-mailadressen verschilt van provider tot provider. Zelfs enkele van de grootste providers zijn niet volledig compatibel met internationale adressen. Met Google kunt u bijvoorbeeld een e-mail verzenden naar een internationaal adres, maar u kunt er geen maken. Outlook 2016 heeft een vergelijkbare functionaliteit.

Conclusie

In tegenstelling tot het domeinnaamgedeelte is het lokale gedeelte van een e-mailadres hoofdlettergevoelig. Dat gezegd hebbende, kiezen veel e-mailproviders om praktische redenen ervoor om de hoofdlettergevoeligheid van het lokale gedeelte te negeren en mensen aan te moedigen om e-mails met alleen kleine letters te maken.

Interessante Artikelen

Editor'S Choice

De beste oplossingen voor een Acer-laptop die niet oplaadt
De beste oplossingen voor een Acer-laptop die niet oplaadt
Wanneer uw laptop niet kan worden opgeladen, verliest u het voordeel van de draagbaarheid die het apparaat zou moeten bieden. Helaas is het achterhalen van het specifieke probleem niet altijd eenvoudig, aangezien er verschillende problemen zijn die uw Acer-laptop kunnen veroorzaken
Een stationsletter wijzigen in Windows 10
Een stationsletter wijzigen in Windows 10
Het wijzigen van stationsletters in Windows heeft zeker zijn voordelen. U kunt een specifiek station verbergen voor alle apps op uw computer, waardoor wordt voorkomen dat deze apps naar een specifieke partitie schrijven of u kunt de stationsletter bewerken nadat u een nieuw station hebt toegevoegd
E-mails automatisch labelen in Gmail
E-mails automatisch labelen in Gmail
https://www.youtube.com/watch?v=a_UY461XSlY Ondanks dat e-mails al meer dan dertig jaar bestaan, nemen e-mails nog steeds vrije tijd in beslag, irriteren, frustreren en irriteren. De vreemde e-mail maakt ons ook blij, maar voor het grootste deel zijn ze dat
Een Reddit-meme vond zijn weg naar een hoorzitting van het Hooggerechtshof
Een Reddit-meme vond zijn weg naar een hoorzitting van het Hooggerechtshof
U zou kunnen denken dat wanneer de gekozen functionarissen van een land een kandidaat voor een vacature bij het Hooggerechtshof onderzoeken, de vragen strikt beperkt zijn tot tweeledige juridische kwesties. Oh, mijn vriend, je hebt veel te veel vertrouwen in democratische processen.
Hoe deel te nemen aan Railjack-missies in Warframe
Hoe deel te nemen aan Railjack-missies in Warframe
Update 29.10 voor Warframe bracht verbeteringen en wijzigingen aan Railjack. De missies, Railjacks zelf en andere aspecten zijn nu veel meer in lijn met de rest van Warframe. Enkele wijzigingen die helpen bij het balanceren van deze functie, zijn onder meer schadetypes, waardoor
Hoe opgeslagen creditcardnummer in Chrome te bekijken
Hoe opgeslagen creditcardnummer in Chrome te bekijken
Dankzij de autofill-optie van Google Chrome kunt u uw creditcardgegevens opslaan en online winkelen veel gemakkelijker maken. Hoewel het opslaan van deze informatie slechts een paar klikken kost, is het bekijken ervan niet zo eenvoudig als u misschien denkt.
Hoe bestanden van de ene Google Drive naar de andere te verplaatsen
Hoe bestanden van de ene Google Drive naar de andere te verplaatsen
Google Drive is, net als veel andere Google-producten, een van de beste cloudopslagservices. Van het bieden van een veilige, gemakkelijk toegankelijke plek voor uw back-ups tot het delen van grote bestanden in de cloud met andere mensen, Google Drive dekt alle basissen.